[Solved] Wifi configuration

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
#1
Hello,

I finished to setup keexybox for website filtering and anonymity topology with a raspberry pi 4.
Wifi form is filled. 
But any wifi signal is broadcast by the raspberry.(As I understand, Pi 4 can act as an AccessPoint natively, Am I wrong?)
Keexybox GUI can't start hostapd service. The service is stopped.

On SSH, Raspberry warn me:
Wi-Fi is currently blocked by rfkill.
Use raspi-config to set the country before use.


raspi-config shows an error when I try to setup WLAN country:
Could not communicate with wpa_supplicant

[email protected]:~ $ cat /etc/wpa_supplicant/wpa_supplicant.conf
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1


[email protected]:/opt/keexybox/hostapd/etc $ cat hostapd.conf
# GENERATED BY KEEXYBOX WEBUI
# DO NOT EDIT THIS FILE

# General
ssid=WifiNobel-keexy
interface=wlan0
bridge=br0
country_code=FR
hw_mode=g
channel=10
wmm_enabled=1
macaddr_acl=0

# Security
ignore_broadcast_ssid=0
auth_algs=1
wpa=2
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP
rsn_pairwise=CCMP
wpa_passphrase=mypassword


Do I miss something?
Reply
#1
Hello,

I finished to setup keexybox for website filtering and anonymity topology with a raspberry pi 4.
Wifi form is filled. 
But any wifi signal is broadcast by the raspberry.(As I understand, Pi 4 can act as an AccessPoint natively, Am I wrong?)
Keexybox GUI can't start hostapd service. The service is stopped.

On SSH, Raspberry warn me:
Wi-Fi is currently blocked by rfkill.
Use raspi-config to set the country before use.


raspi-config shows an error when I try to setup WLAN country:
Could not communicate with wpa_supplicant

[email protected]:~ $ cat /etc/wpa_supplicant/wpa_supplicant.conf
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1


[email protected]:/opt/keexybox/hostapd/etc $ cat hostapd.conf
# GENERATED BY KEEXYBOX WEBUI
# DO NOT EDIT THIS FILE

# General
ssid=WifiNobel-keexy
interface=wlan0
bridge=br0
country_code=FR
hw_mode=g
channel=10
wmm_enabled=1
macaddr_acl=0

# Security
ignore_broadcast_ssid=0
auth_algs=1
wpa=2
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP
rsn_pairwise=CCMP
wpa_passphrase=mypassword


Do I miss something?
Reply
#2
Solved with the command:
rfkill unblock wlan
Reply
#2
Solved with the command:
rfkill unblock wlan
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)