Example network setup/topologies

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
#1
Hi everyone,



A bit of a setup guides for newbies like me.

It took me a while to setup Keexybox mainly because I made it hard for myself.  I wanted to replicate:

[Image: keexybox_net_topology_as_gateway_v2.png?...tok=ef853b]



with my router changed to:

 - IP address: 192.168.1.200/24;

 - I moved the DNS across to OpenDNS DNS entries:

  - 208.67.222.222 and 208.67.220.220

 until I setup a cron job to update the Blacklists.

I wanted the internal network to be: 10.0.0.0/24
and the output network to be: 192.168.1.0/24.



I thought it might be worthwhile showing what setups worked where you have two separate networks.



So Keexybox is:

 - eth0: 192.168.1.254;

 - etho:0: 10.0.0.1/24 for the input network, looks like (attachment: keexybox network screen 1.png)

and then your DHCP looks like attachments: keexybox dhcp screen 1.png and keexybox dhcp screen 2.png

I performed an update of the Raspberry Pi as well via bash shell:
Code:
$ ssh [email protected]
password: <default>
# change your <default> password with:
$ passwd
# update the raspberry pi
$ sudo apt-get update
$ sudo apt-get upgrade
which introduced a new DHCP client dhcpcd.service which breaks the existing one.  Disable it:
$ sudo systemctl disable dhcpcd.service

and check that none of the interfaces are set to DHCP, they should be static:
Code:
$ cd /etc/network
$ less interfaces

This is generated by KeexyBox so make sure your entries are correct according to the screen shots, mine looks like:
Code:
# GENERATED BY KEEXYBOX WEBUI
# DO NOT EDIT THIS FILE

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# Auto load interfaces
auto lo eth0 eth0:0
iface lo inet loopback

# Hotplug interfaces
allow-hotplug eth0 eth0:0


# Output network configuration
iface eth0 inet static
    address 192.168.1.254
    netmask 255.255.255.0
    gateway 192.168.1.200
    dns-nameservers 192.168.1.200 208.67.222.222

# Internal network configuration
iface eth0:0 inet static
    address 10.0.0.1
    netmask 255.255.255.0

Then disable DHCP on the router (192.168.1.200) and let Keexybox restart:
Code:
$ sudo systemctl reboot


Attached Files Thumbnail(s)
           
Reply
#1
Hi everyone,



A bit of a setup guides for newbies like me.

It took me a while to setup Keexybox mainly because I made it hard for myself.  I wanted to replicate:

[Image: keexybox_net_topology_as_gateway_v2.png?...tok=ef853b]



with my router changed to:

 - IP address: 192.168.1.200/24;

 - I moved the DNS across to OpenDNS DNS entries:

  - 208.67.222.222 and 208.67.220.220

 until I setup a cron job to update the Blacklists.

I wanted the internal network to be: 10.0.0.0/24
and the output network to be: 192.168.1.0/24.



I thought it might be worthwhile showing what setups worked where you have two separate networks.



So Keexybox is:

 - eth0: 192.168.1.254;

 - etho:0: 10.0.0.1/24 for the input network, looks like (attachment: keexybox network screen 1.png)

and then your DHCP looks like attachments: keexybox dhcp screen 1.png and keexybox dhcp screen 2.png

I performed an update of the Raspberry Pi as well via bash shell:
Code:
$ ssh [email protected]
password: <default>
# change your <default> password with:
$ passwd
# update the raspberry pi
$ sudo apt-get update
$ sudo apt-get upgrade
which introduced a new DHCP client dhcpcd.service which breaks the existing one.  Disable it:
$ sudo systemctl disable dhcpcd.service

and check that none of the interfaces are set to DHCP, they should be static:
Code:
$ cd /etc/network
$ less interfaces

This is generated by KeexyBox so make sure your entries are correct according to the screen shots, mine looks like:
Code:
# GENERATED BY KEEXYBOX WEBUI
# DO NOT EDIT THIS FILE

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# Auto load interfaces
auto lo eth0 eth0:0
iface lo inet loopback

# Hotplug interfaces
allow-hotplug eth0 eth0:0


# Output network configuration
iface eth0 inet static
    address 192.168.1.254
    netmask 255.255.255.0
    gateway 192.168.1.200
    dns-nameservers 192.168.1.200 208.67.222.222

# Internal network configuration
iface eth0:0 inet static
    address 10.0.0.1
    netmask 255.255.255.0

Then disable DHCP on the router (192.168.1.200) and let Keexybox restart:
Code:
$ sudo systemctl reboot


Attached Files Thumbnail(s)
           
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)