Statistics does not show up

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
#1
Hi,
   Excited to see this project something which I was looking for quite some years honestly. Followed the installation instructions. As a first step just wanted to enable "Use Keexybox for website only" topology. Gave the ip address of the keexybox as the primary dns in my router. Didn't assign any DNS1 or DNS2 in the keexybox. Just set only the Router Gateway. I have also enabled statistics in the dfeault profile (which is what I am using). Despite all these efforts, could not get the statistics. Upon ssh, I see the log file remains 0 bytes. Not sure what' the mistake is. Have the latest version 20.10.2. Any pointers could help. Spent more than 1 week  Sad nearly now.
Reply
#1
Hi,
   Excited to see this project something which I was looking for quite some years honestly. Followed the installation instructions. As a first step just wanted to enable "Use Keexybox for website only" topology. Gave the ip address of the keexybox as the primary dns in my router. Didn't assign any DNS1 or DNS2 in the keexybox. Just set only the Router Gateway. I have also enabled statistics in the dfeault profile (which is what I am using). Despite all these efforts, could not get the statistics. Upon ssh, I see the log file remains 0 bytes. Not sure what' the mistake is. Have the latest version 20.10.2. Any pointers could help. Spent more than 1 week  Sad nearly now.
Reply
#2
Hi,

Which one of KeexyBox or your router provides the DHCP ?
I understand that DHCP is provided by your router and you tried to set KeexyBox IP address as primary DNS on the DHCP configuration of your router. That's right ?

In this configuration, if devices (laptop, phones...) did not get DNS server by router DHCP, it looks likes a router issue. In this case, DHCP on KeexyBox have to be disabled and it is recommended to set KeexyBox Output network IP address as DNS in the DHCP configuration of your router.

About statistics, you won't get them until your devices are not using KeexyBox DNS and devices and users not connected thru KeexyBox (users should be automaticaly redirected to KeexyBox's captive portal to connect the internet if KeexyBox IP address is set as DNS on the devices they use).

Can you tell me which of KeexyBox services are started or not started?
http://192.168.2.254:8001/tools/services

Can you give me an output of iptables status?
http://192.168.2.254:8001/tools/iptables-status
Reply
#2
Hi,

Which one of KeexyBox or your router provides the DHCP ?
I understand that DHCP is provided by your router and you tried to set KeexyBox IP address as primary DNS on the DHCP configuration of your router. That's right ?

In this configuration, if devices (laptop, phones...) did not get DNS server by router DHCP, it looks likes a router issue. In this case, DHCP on KeexyBox have to be disabled and it is recommended to set KeexyBox Output network IP address as DNS in the DHCP configuration of your router.

About statistics, you won't get them until your devices are not using KeexyBox DNS and devices and users not connected thru KeexyBox (users should be automaticaly redirected to KeexyBox's captive portal to connect the internet if KeexyBox IP address is set as DNS on the devices they use).

Can you tell me which of KeexyBox services are started or not started?
http://192.168.2.254:8001/tools/services

Can you give me an output of iptables status?
http://192.168.2.254:8001/tools/iptables-status
Reply
#3
(04-06-2021, 06:52 AM)srini_srinis Wrote: Hi,
   Excited to see this project something which I was looking for quite some years honestly. Followed the installation instructions. As a first step just wanted to enable "Use Keexybox for website only" topology. Gave the ip address of the keexybox as the primary dns in my router. Didn't assign any DNS1 or DNS2 in the keexybox. Just set only the Router Gateway. I have also enabled statistics in the dfeault profile (which is what I am using). Despite all these efforts, could not get the statistics. Upon ssh, I see the log file remains 0 bytes. Not sure what' the mistake is. Have the latest version 20.10.2. Any pointers could help. Spent more than 1 week  Sad nearly now.

Which one of KeexyBox or your router provides the DHCP ?
I understand that DHCP is provided by your router and you tried to set KeexyBox IP address as primary DNS on the DHCP configuration of your router. That's right ?
[SS] Router provides the DHCP service. DHCP service is disabled in KeexyBox in the Network Page. On another note, I cannot set the KeexyBox DNS in individual machine (due to restrictions). The primary DNS I have specified in my router is 192.168.1.148. This is where my Keexybox is running. I changed it to this address because, my DHCP server said it can allocate IP address only from 192.168.1.100 through 192.168.1.148


Attached Files Thumbnail(s)
           
Reply
#3
(04-06-2021, 06:52 AM)srini_srinis Wrote: Hi,
   Excited to see this project something which I was looking for quite some years honestly. Followed the installation instructions. As a first step just wanted to enable "Use Keexybox for website only" topology. Gave the ip address of the keexybox as the primary dns in my router. Didn't assign any DNS1 or DNS2 in the keexybox. Just set only the Router Gateway. I have also enabled statistics in the dfeault profile (which is what I am using). Despite all these efforts, could not get the statistics. Upon ssh, I see the log file remains 0 bytes. Not sure what' the mistake is. Have the latest version 20.10.2. Any pointers could help. Spent more than 1 week  Sad nearly now.

Which one of KeexyBox or your router provides the DHCP ?
I understand that DHCP is provided by your router and you tried to set KeexyBox IP address as primary DNS on the DHCP configuration of your router. That's right ?
[SS] Router provides the DHCP service. DHCP service is disabled in KeexyBox in the Network Page. On another note, I cannot set the KeexyBox DNS in individual machine (due to restrictions). The primary DNS I have specified in my router is 192.168.1.148. This is where my Keexybox is running. I changed it to this address because, my DHCP server said it can allocate IP address only from 192.168.1.100 through 192.168.1.148


Attached Files Thumbnail(s)
           
Reply
#4
Everything looks fine at the KeexyBox side.
In the iptables output I can see the user with IP 192.168.1.144 is connected to keexybox,
but it also shows that KeexyBox did not recieve any traffic from 192.168.1.144.
It look that the default profile has time restriction (3:30 to 4:55 UTC). You should remove this time restriction for your tests.

Can you check if your machines get the right KeexyBox's DNS? On windows you can use:
Code:
ipconfig /all | findstr DNS

Maybe you have also restrictions to get the DNS on your machines from a DHCP.
The key to the solution is that the machines use KeexyBox DNS.
Reply
#4
Everything looks fine at the KeexyBox side.
In the iptables output I can see the user with IP 192.168.1.144 is connected to keexybox,
but it also shows that KeexyBox did not recieve any traffic from 192.168.1.144.
It look that the default profile has time restriction (3:30 to 4:55 UTC). You should remove this time restriction for your tests.

Can you check if your machines get the right KeexyBox's DNS? On windows you can use:
Code:
ipconfig /all | findstr DNS

Maybe you have also restrictions to get the DNS on your machines from a DHCP.
The key to the solution is that the machines use KeexyBox DNS.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)